Kbase P7653: Multiple Progress Servers cannot be started via ProControl
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/11/2008 |
|
Status: Verified
SYMPTOM(s):
Multiple Progress Servers cannot be started via ProControl
<database> ERROR cannot Find Lock (.lk) file. See EVENT VIEWER. (5780)
** The server terminated with exit code 1. (800)
Shared memory in use by a process other than PROGRESS. (8872)
Progress server cannot be started via ProControl
mprosrve dbname generates same errormessages 5780 800 8872
idxfix generates same errormessages 5780 800 8872
truncate bi gives same 8872 error message
prostrct repair gives same 8872 error message
FACT(s) (Environment):
Database on NTFS partition
Permissions of the folder and files where Progress database is installed are read/write
Database has NOT been started outside ProService
ProService is started with the System Account
Services file has no "/" characters in services names
Startup parameters all verified as correct
Service / Host name spelled exactly the same as registered in Services / Host file
Reboot server did not resolve issue
Windows
Progress 7.x
Progress 8.x
Progress 9.x
CAUSE:
The databases and application code were all in the same directory. When this was the case, only one (sometimes two) databases would start. Even after rebooting the machine, all databases would not start. Moving databse files gives them a different inode number and therefore a different shmid value from the algorithm that is stored in the master block, will resolve this circumstance.
FIX:
Move the databases to a seperate "database" directory.
Repair the control area to reflect the new location: prostrct repair dbname dbname.st file
and adjust the startup settings in ProControl to account for their new location.