Consultor Eletrônico



Kbase P7482: Error 8089 connecting to an AppServer when approaching the max number of servers
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Verified

FACT(s) (Environment):

Progress 9.x

SYMPTOM(s):

Error 8089 when number of busy is close to max setting

ERROR: No servers available. (8089)

Error 8089 in broker log file

AppServer running in Stateless mode

No error messages in the server.log file at the time error 8089 appears in the broker.log file.

CAUSE:

You have exceeded the maximum number of AppServer servers available.

On a Stateless AppServer, this may happen when the number of simultaneous client requests is approaching the maximum number of servers available.

At any given time there may be some AppServer servers which have finished serving a client request and have disconnected from it, yet they are not back in the AVAILABLE state yet (due to some small internal latencies). When the workload on the AppServer is approaching the limit of maximum servers, this is what may happen (given that N is the maximum number of AppServer servers):

- (N - 1) AppServer servers are serving requests from (N - 1) clients. At the same time, the Nth AppServer server is going back to AVAILABLE after finishing serving a client request.
- A new client request comes in.
- The broker cannot find any available AppServer server: from its point of view all servers are busy (including the one which is going back to AVAILABLE).
- Error 8089 is generated, and the client request is refused even though only (N - 1) other clients are being served.

FIX:

Increase the maximum number of AppServer servers available.