Consultor Eletrônico



Kbase P7385: ODBC driver cannot be found when trying to configure the Datasource on Windows
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/9/2004
Status: Verified

FACT(s) (Environment):

Progress 9.1x

SYMPTOM(s):

Error when attempting to configure the ODBC Datasource

MERANT 3.60 32-BIT PROGRESS SQL92 v9.1x ODBC driver could not be found. Please reinstall the driver.

Information about the ODBC driver is missing (version, file, etc) under the Datasource driver tab

The PGPRO915.dll driver dll is under the %DLC%\bin directory

CAUSE:

The user account installing Progress product (including the MERANT driver) couldn't create the registry entries related to the ODBC driver.

FIX:

Create manually the necessary registry entries under the ODBCINST.INI folder for the driver (regedit).

For example 9.1d of the necessary entries:

[HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\MERANT 3.60 32-BIT Progress SQL92 v9.1D]
"APILevel"="1"
"ConnectFunctions"="YYN"
"CPTimeout"="60"
"Driver"="u:\\91c\\bin\\PGPRO915.DLL"
"DriverODBCVer"="3.60"
"FileUsage"="0"
"Setup"="u:\\91c\\bin\\PGPRO915S.DLL"
"SQLLevel"="0"
"UsageCount"="1"

*where u:\91d is the Progress installation directory (%DLC%)

In addition to this, open the registry editor and locate the key:
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers
Add the string value:
MERANT 3.60 32-BIT Progress SQL92 v9.1D
with value data:
Installed