Consultor Eletrônico



Kbase P6967: Non-domain access clients cannot connect to a progress session
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   11/11/2008
Status: Verified

SYMPTOM(s):

Unable to start client session

Client cannot connect to the Progress session

When the client HAS domain access rights, Progress session starts

When the client DOES NOT HAVE domain access rights, Progress flashes and closes

File permissions are different to previous server

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000
Progress 9.1D
Progress 9.1E
OpenEdge 10.x

CHANGE:

New Windows2000 Server installed

CAUSE:

Non-domain access right users do not have permissions correctly set for Progress executables, database files and connection parameter files.

FIX:

The IT Administrator needs to check the access permissions for the non_domain _access_user in the following areas:


1.) Read permissions on the connection parameter files such as:
startmenu.bat, <dbname>.ini, <dbname>.pf

2.) Read and write permissions for the:
+ directory where the database resides
+ Temporary Directory (-T) if connection or path is not local
+ Database files (the .db, .lg, and .bi)
+ Progress executables in DLC\bin (_progress, _mprosrv, _mprshut, _proutil

3.) Review permissions on the Domain Controller and how these are passed to the server where Progress is installed.