Kbase P6964: Client connections unable to open message file:PROMSGS.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  11/11/2008 |
|
Status: Verified
SYMPTOM(s):
Client connections unable to open message file:PROMSGS.
msgOpen: unable to open message file:PROMSGS
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
Progress/OpenEdge Product Family
CHANGE:
New WINDOWS 2000 server installed
CAUSE:
This error usually has to do with that the Progress installation is unable to find the PROMSGS file. This could be caused by some Progress related environment variable (such as DLC) is pointing to the wrong location, or the permissions set in the Domain Controller and the Server where Progress is installed are out of sync.
FIX:
Four environment variables have to be set before Progress can work from a Command prompt. Assuming that you installed in the directory, C:\DLC, these are:
DLC=C:\DLC
PROMSGS=%DLC%\PROMSGS
PROCFG=%DLC%\PROGRESS.CFG
PATH=%PATH%;%DLC%;%DLC%\BIN
Verify these by:
1) Open a DOS window
2) Type: Set > set.txt
3) View this file in Notepad.
Another reason is that the file permissions are out of sync, for example:
If a user can connect if user has Domain Access Rights, but cannot connect if they don't. In this case the permissions set in the Domain controller should be be reviewed by a WINDOWS expert, possibly the user concerned does not have permissions to access PROMSGS?
In order to initially workaround this issue:
create a local PROMSGS environment variable on the client and set the value of this variable to point to the promsgs file stored locally. PROMSGS can be copied from the the DLC directory.