Kbase P6217: Users can't create or access ODBC DSN's due to registry key rights (priveledges).
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/15/2008 |
|
Status: Verified
FACT(s) (Environment):
Windows NT 4.0 Terminal Server Edition
Windows 2000 Advanced Server
MERANT 3.60 32-BIT Progress SQL-92
DataDirect 4.1 32-Bit Progress SQL92 9.1D
Progress 9.1x
SYMPTOM(s):
MERANT 3.60 32-BIT PROGRESS SQL92 v9.1c ODBC driver could not be found.
Please reinstall the driver.
Error occurs when attempting to configure an ODBC DSN for a user that does not have local administrator rights (privileges).
Users cannot see DSN information in the ODBC Datasource Administrator.
ODBC driver resides on a Microsoft Terminal Services machine.
Users with local administrator rights (privileges) can see DSN information.
Users with local administrator rights (privileges) can create new DSN entries.
CAUSE:
User or UserGroup does not have rights (privileges) to access the following Windows registry key:
HKEY_LOCAL_MACHINE\Software\ODBC\ODBCINST.INI\MERANT 3.60 32-BIT Progress SQL92
v9.1x
FIX:
Log into Windows Terminal Server machine using the local administrator account. Run regedt32.exe. Navigate to the following registry key:
HKEY_LOCAL_MACHINE\Software\ODBC\ODBCINST.INI\MERANT 3.60 32-BIT Progress SQL92
v9.1x
Select the following menu option:
Security -> Permissions
Assign the individual user(s) or UserGroup access to this registry key.