Kbase P57156: Could not restore database from unzipped file with Tranman
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  12/5/2003 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.1D
FACT(s) (Environment):
Translation Manager 2.0
SYMPTOM(s):
Could not restore database from unzipped file with Tranman
Could not restore database from unzipped file.
Unzip operation aborted.
When installing a kit the unzip of the zip file fails to unzip correctly.
CAUSE:
This is because the session working directory is different from the directory where the zip file resides and is being unzipped to. So when the file is unzipped, the restore of the database is placed in the Progress working directory, not the directory specified in the Project directory fillin.
There should also be a file named 'pnnnnnbku.sta' (where 'nnnnn' is an incrementing sequence number), that indicates why the restore of the database failed. This could be in the working directory or Temp directory.
FIX:
Create an icon to start Visual Translator with a specific starting directory. This directory should be the one that contains the zip file, and the directory specified in the Project directory fillin when unzipping.