Kbase P54594: Clients can't connect, and errors 6091, 291, 6092, 794, 290,
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  18/11/2003 |
|
Status: Unverified
FACT(s) (Environment):
AIX 4.3.3
FACT(s) (Environment):
Progress 9.1B
SYMPTOM(s):
Clients can't connect, and errors 6091, 291, 6092, 794, 290, 3645 appear in lg file
Clients getting error 1432
** Could not connect to server for database <DATABASE>, errno 0. (1432)
<function>:Insufficient disk space during <system call>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (6091)
Insufficient disk space or Write access denied. (291)
<function>:Unknown O/S error during <system call>, errno <error number>, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (6092)
Usernum terminated abnormally. (794)
SYSTEM ERROR: I/O error <n> in <program>, ret <n>, file <n>, addr <n>. (290)
bkwrite: write to disk failed errno <num>. (3645)
Clients connecting over terminal server.
CAUSE:
Taken together the errors suggest a network/system issue.
The 6091 message doesn't necessarily mean that disk space is the problem, but is sometimes reported in situations where for some other reason Progress can·t access the disk.
Similar goes for the 291 -
Insufficient disk space or Write access denied. (291)
Generally, people focus on the disk space part of the message, and discount the second part. The second part doesn't just indicate permissions problem, but can also mean that the file can't be found.
If the 6092 message is being reported by a Windows client (check the corresponding 5512 message), so the errno 2 is a Windows errno -
2L ERROR_FILE_NOT_FOUND The system cannot find the file specified.
The 3645 can also report the same -
bkwrite: write to disk failed errno 2. (3645)
The 794 can be due to a user killing their session in Task Manager, or it can be a due to a network error.
So the trend in this situation would seem to indicate that there is a network issue.
FIX:
Check your network for network problems - discuss how to do this with your network provider as necessary.
If the network is running on Windows, for instance, the Event Viewer logs could shed light on this. Any errors or behaviours being reported there for the times the Progress errors and the login behaviour are appearing?