Consultor Eletrônico



Kbase P54432: Lost connection to the network
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   16/10/2008
Status: Verified

FACT(s) (Environment):

Windows XP

SYMPTOM(s):

Lost connection to the network

Network cable is unplugged

AdminService is not running

It is not possible to restart AdminServer

Windows message when trying to start AdminService: "The AdminService for PROGRESS 9.X service on local computer started and then stopped"

CAUSE:

Java process hangs when network connection is lost causing the adminserver not to start

FIX:

The way to address this is by installing the Microsoft Loopback adapter. To install this on Windows, do the following (the steps may vary from one version of Windows to the other, please contact Microsoft's documentation for your version of Windows) :

1. Control Panel, Add Remove Hardware
2. Add Hardware Wizard
3. Add a new device, hardware device (at the bottom) - <Next>
4. Add the hardware that I manually select from a list <next>
5. Network adapters <Next>
6. <Manufacturer Microsoft> - Microsoft Loop Back adapter <Next>
7. <Next>
8. <Finish>
9. Reboot

The loopback adapter simulates being connected to a network, and therefore should resolve this issue.

A second solution would be to kill the java.exe processes running and start AdminService again.