Consultor Eletrônico



Kbase P53118: Client hangs on SCO OpenServer whenconnecting to a Progress AppServer broker, after the upgrade to 9
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/16/2008
Status: Verified

FACT(s) (Environment):

Progress 9.1B
Progress 9.1C
SCO OpenServer

SYMPTOM(s):

JDK 1.1.7

Client hangs when run from a SCO OpenServer machine connecting to a Progress AppServer broker.

Error occurs when running application:

ERROR: CSOPTTABNREQUEST: protocol error

ERROR: Communication layer message: <message text>. (7175)

ERROR: Client Communications Failure - <Java Exception> (8409)

The Java client generates:

com.Progress.open4gl.Open4GLException:
Communication layer message:
Client Communications Failure - java.net.SocketException:
Socket read failed (8409). (7175)

The OSRCompat Binary Compatibility Module (BCM) has been installed.

Applied Sco OpenServer Patch OSS630.

CHANGE:

migrate from Progress 9.1B to 9.1C

CAUSE:

Migrating Progress from 9.1B to 9.1C requires the upgrade of the JDK from 1.1.7 to 1.1.2.

FIX:

Upgrade the JDK version from 1.1.7 to 1.1.2.

JDK 1.1.2 requires OSRcompat 7.1.1. Installing the OSRcompat 7.1.1 might overwrite the OSS630 patch. The patch should be reapplied after the install of the OSRCompat.