Consultor Eletrônico



Kbase P52657: Autostart database hangs on startup with 8490 and 8486 error
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/4/2004
Status: Verified

FACT(s) (Environment):

Progress 9.1C

SYMPTOM(s):

Databases managed by the AdminServer.

Autostart database hangs on startup with 8490 and 8486 error in admserv.log.

Databases started in sequence from Progress Explorer.

Database starting later in the sequence hangs.

Abnormal communication failure for config: (8490)

In crash handler for config . (8486)

Upgrade to the latest version of Progress is not possible

CAUSE:

Bug #20011009-008

CAUSE:

Fixed in last patch to 9.1C and base 9.1D.

On occasion some databases managed by the AdminServer would not register at the AdminServer startup. The problem was determined to be with the AdminServer not waiting long enough for the databases to start.

FIX:

Perform the workaround noted below.

- increase RTInitializing from 4 (seconds) to 30 seconds; this is the number of
seconds the AdminServer waits to get an initialization acknowledgement.
- increase RTStarting from 4 (seconds) to 30 seconds; this is the number of seconds the AdminServer wait to get a starting acknowledgement.
- increase RTShuttingDown from 0 (seconds) to 30 seconds

How to increase the timeouts:

- Stop the AdminServer
- Add the above recommendations to a file, say "newTimings" for example, in
the form:

RTInitializing=30
RTStarting=30
RTShuttingDown=30

- Add the java property, -DConfigToolTimings=<dirPath>
ewTimings, to the
AdminServer startup command. This can be done by modifying the proadsv file to include this java property or by adding the property to the "JVMARGS" environment variable.
- Restart the AdminServer.