Consultor Eletrônico



Kbase P51078: Unable to find NS1 error when starting it using nsman command
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/09/2008
Status: Verified

SYMPTOM(s):

Unable to find NS1 error when starting it using nsman command

Searching for NS1 (8288)

Unable to connect to NS1 (8289)

Unable to find NS1 (8281)

FACT(s) (Environment):

The problem came up after restarting of the WebSpeed Transaction Server due to the NameServer hung
NameServer and the WebSpeed Transaction Server are on the same machine
Admin server and the Webspeed brokers are running fine
NameServer is set to auto start upon starting AdminServer
WebSpeed Transaction Server is inside the firewall
Replacing the ubroker.properties.template as ubroker.properties file fixed the problem.
All Supported Operating Systems
Progress 9.x
OpenEdge 10.0x

CAUSE:

Somehow the ubroker.properties file got corrupted perhaps from editing it.

FIX:

Replace the ubroker.properties file with the template and carefully edit to add the additional brokers.