Kbase P4944: 1890 error, caused by lack of available memory, preventing remote clients from connecting to the da
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  5/26/2005 |
|
Status: Unverified
FACT(s) (Environment):
Progress 9.x
SYMPTOM(s):
Remote users cannot connect to the database.
Using Progress Explorer and AdminServer to manage the AppServer
Using ProControl and ProService to manage the databases
Error 1890 in the database log file:
BROKER: Could not spawn a server. (1890)
The PC is "paging memory"
CAUSE:
The combined resources needed to run both ProService and AdminServer is too great for the machine. The AdminServer uses JAVA which can take up a lot of memory. The paging indicates more memory is needed.
FIX:
Use Progress Explorer and AdminServer to manage both the databases and the AppServers. ProControl is no longer being enhanced (in the future, it is scheduled to be removed from Progress).
Alternatively, add more memory to your machine.