Kbase P47958: WebSpeed broker fails to start because it takes long time for agents to connect to database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/15/2008 |
|
Status: Verified
FACT(s) (Environment):
WebSpeed 3.1x
SYMPTOM(s):
WebSpeed broker fails to start
ERROR: cannot start server. (8100)
Timeout while listening for server : java.io.InterruptedIOException: Accept timed out
Agents connect the database at the startup
Database log file shows long time in between the agent startup and the connection
WebSpeed 3.1x connects to remote database server
CAUSE:
Some of the agents failed to connect to the database as the network connection
took excessively long time
FIX:
The fix to this problem is to determine the reason for the excessively long
time required to connect to the database and fix that. Then restart webspeed broker.