Consultor Eletrônico



Kbase P47046: Error 290 with Progress clients using Windows 2000 TS SP3 or SP4 with application deployed on a netw
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   07/12/2009
Status: Verified

SYMPTOM(s):

Intermittent client disconnects with error 290

SYSTEM ERROR: I/O error <n> in <program>, ret <n>, file <n>, addr <n>. (290)

SYSTEM ERROR: I/O error 22 in readit, ret -1, file <n>, addr 0. (290)

I/O Errors on Windows 2000 Terminal Services / Metaframe

client server application

Progress application files are stored on a network drive

Windows and Citrix have the latest patches and Service Packs applied

No hardware issue on the client system

Error 290 with readit error 22 when starting application

Windows 2000 SP3 or SP4 installed

FACT(s) (Environment):

Windows 2000
Citrix MetaFrame (for Windows 2000 Terminal Server)
Citrix WinFrame
Windows 2000 Advanced Server
Windows 2003
Windows XP

CAUSE:

This is a known Microsoft issue with Windows 2000 using mapped drives and network shares. Users running programs from Network shares or mapped drives may see programs close or generate errors when another Terminal Services user logs out of the session.

For further information please take a look at the following MS Knowledge Base documents:
http://support.microsoft.com/?kbid=294816
http://support.microsoft.com/?kbid=818528
http://support.microsoft.com/?kbid=299603

FIX:

Option 1: Disable opportunistic locking on the Windows 2000 Server.

For information on how to Configuring Opportunistic Locking in Windows
please see: Microsoft Knowledge Base Article - 296264

Option 2: Move the Progress application files locally to the TS / Citrix server.