Kbase P4659: Abnormal Database shutdown after HANGUP error followed by 5028 and 5026
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/10/2008 |
|
Status: Verified
SYMPTOM(s):
Abnormal Database shutdown after HANGUP error followed by 5028 and 5026
The following errors can be found in the database log file (.lg)
HANGUP signal received. (562)
Begin transaction backout. (2252)
SYSTEM ERROR: Releasing regular latch. latchId: 20 (5028)
SYSTEM ERROR: Releasing regular latch. latchId:<latch-num> (5028)
User <n> died holding 1 shared memory locks. (5026)
User <num> died holding <num> shared memory locks. (5026)
Begin ABNORMAL shutdown code 2 (2249)
Begin ABNORMAL shutdown code (2249)
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
All Supported Operating Systems
CAUSE:
This is an expected behavior. When a hang up signal is received by the process and this process no longer responds, the broker or the watchdog process must clean up this connections and release everything related to this process. During the transaction backout sometimes a latch need to be release. Since a latches are shared memory structures and in order to release a latch, a shared memory locks must be released. In some situations where the release of the shared memory locks cannot be resolved gracefully, and therefore, in order to maintain the integrity of the database, it needs to bring down the database.
FIX:
Resolve the reason(s) of the "HANGUP signal received" by identifying the cause. Some common cases where a hang up can happen are:
- users disconnect their session without leaving properly their Progress session
- a telnet session is "lost" while a Progress session is running
- a "kill" commmand has been issued at the OS level on the Progress process
Alternatively, by using Client/Server mode (started a DB server with -S parameter and have client sessions connect to the DB adding that -S parameter) can help because a Remote Server will be handling the locks in Shared Memory.