Consultor Eletrônico



Kbase P46062: OpenEdge AdminService fails to start after installation of OpenEdge
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/9/2010
Status: Verified

SYMPTOM(s):

OpenEdge AdminService fails to start after installation of OpenEdge 10

Multiple versions of Progress are installed on the same machine

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

Message (throw): Failed to register admin server.

Message (excp): Could not start RMI Registry

Cannot connect to OpenEdge AdminService after installation of OpenEdge 10

FACT(s) (Environment):

Progress 9.1X
OpenEdge 10.X
Windows

CAUSE:

AdminServer of 9.1X has been already running on port 20931 (default port), so both AdminServers are trying to start using default port 20931. This will work for the first one, but not for the other one.

FIX:

If you want to have both of them started, you must change a port for AdminService and adminport for Progress 9.1X or for OpenEdge 10.0A.

This can be done from command line -> proadsv -start -port 20933 -adminport 3456 (example), or you can make these changes permanent in the registry (for 9.1X or 10.0A)

For 9.1X
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\9.1X\ShutdownCmd
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\9.1X\StartupCmd

For 10.0X
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\10.0X\ShutdownCmd
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\AdminService\10.0X\StartupCmd

Modify the Chimera entry, ie add "-port 20933" to the end of ShutdownCmd and "-port 20933 -adminport 3456" to the end of StartupCmd without "", or pick up your own port number

Same port (20933) must be specified in the Progress Explorer as well in order to establish a connection.