Kbase P42726: Clients cannot connect to database (792) (2266) (2268)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/06/2009 |
|
Status: Verified
SYMPTOM(s):
Clients cannot connect to database (792) (2266) (2268)
Message received with bad usernum. (792)
Expected user <user> received user <usernum>. (2266)
Invalid message was received for an attempted login. (2268)
When clients tried to log in they were greeted by a blank screen
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.1x
OpenEdge 10.x
full diagnostic check proved negative
could not stop or start databases remotely
reboot of machine stabilized the situation
killing server processes, removed shared memory segments DID NOT WORK
CAUSE:
These Progress error messages are merely reporting the reason that the client connection was declined in terms of the packets that the Network delivered:
A (PROGRESS) network packet has been sent to the server from the client with the wrong user identifier in it (792). The socket that the server was listening on received this invalid message, where the message header on that socket was supposed to be for the expected user, however the message had the received NO user number in it (2266), which is then rejected by returning the 2268 error message. Resulting in no connection being made for the user logging in.
The Network Interface Card (NIC) is transmitting corrupted packages and disturbing network traffic of clients. Faulty network cards and cable connections need investigating. In this case, the system log files reported that on the wide node there were errors indicative of a faulty fibre connection.
FIX:
Address the Network errors reported or identified through inspection.