Consultor Eletrônico



Kbase 15769: Unable to Find Host in /etc/hosts (780)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   29/09/2004
Status: Verified

SYMPTOM(s):

Unable to find host <name> in /etc/hosts. (780)

TCP/IP software is unable to resolve the hostname to internet address (NOT ip address).

CAUSE:

To communicate TCP/IP, every 'human readable' entry (host, service, protocol, etc.) has to be translated into internet numbers.  PROGRESS makes use of the available 'translation' functions to get the needed information.  For example, -H protsc will pass 'protsc' to a function called gethostbyname(), which in turn will try to resolve the protsc string to an internet host address.  The same schema can be used for the services (port/protocol combinations).  Also, all data is converted to internet format and back.  As a result, an Intel based computer can communicate with a RISC based one (which has different data formats).

Error (780) is a symptom of bad TCP/IP configuration/installation.

It is not a PROGRESS problem.


FIX:

Make sure the TCP/IP software is configured to check the 'hosts' file in the appropriate directory (e.g. \WINDOWS for MSTCP, \NET\TCP for Novell's LAN Workplace etc.), or use the appropriate hostname resolution schema (like WINS on Microsoft systems).

For WINDOWS systems, make sure you have only one WINSOCK.DLL in your system path (PATH variable) and that it is the one provided by the TCP/IP software vendor.  You cannot just copy any WINSOCK.DLL because the implementation differs among TCP/IP software vendors (For example, WINSOCK.DLL from LAN Workplace 4.x depends upon WSOCKETS.DLL; in this case the WINSOCK.DLL is only an API wrapper).  The WINSOCK 1.1 standard only defines an API, not the implementation
of it.  So every vendor will have his own code behind the API.

Make sure the WINSOCK.DLL is not corrupted in any way (try reinstalling the TCP/IP software).

To make sure the TCP/IP software is running fine, try to PING the host using the hostname and the appropriate PING utility (DOS ping for DOS PROGRESS, WINSOCK PING for Windows PROGRESS, etc.).

Check the TCP/IP configuration manual to set TCP/IP database files (hosts, services, etc.)

This also applies to name resolution using DHCP/WINS, DNS or whatever schema is being used.