Kbase P41622: Getting error 'PROMSGS file may have been deleted' when trying to start a client process
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  25/10/2007 |
|
Status: Unverified
FACT(s) (Environment):
Windows
Progress 9.x
OpenEdge 10.x
SYMPTOM(s):
Trying to launch the Progress client executable (prowin32.exe)
errno = 0 reading PROMSGS file, it may have been deleted
errno = 2 reading PROMSGS file, it may have been deleted
Unable to format message number 4279
Progress has just been installed
There is an earlier version of Progress already installed on the same machine
CAUSE:
The PROMSGS environment variable was being set in the autoexec.bat file and it was pointing to the wrong file
FIX:
Remove the PROMSGS entry from the autoexec.bat file before installing the new Progress version.
If PROMSGS variable points to an older or no-existent PROMSGS file, then InstallShield may not write all necessary data to the registry.