Kbase P414: A Previous Installation of the Same Version Has Been Detected.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  16/10/2008 |
|
Status: Verified
FACT(s) (Environment):
Windows 32 Intel
Windows NT 32 Intel/Windows 2000
SYMPTOM(s):
Error: "A previous installation of the same version has been detected. You must uninstall the previous installation before continuing".
The Automatic Uninstall utility fail.
Error when uninstalling a shared network installation (NetSetup) from a client.
CAUSE:
The correct procedure for uninstalling a shared network installation of Progress can be done from Control Panel -> 'Add/Remove Programs'.
If the Uninstall for some reason would fail, a re-install of the same software on the client will fail. The following message will appear:
"A previous installation of the same version has been detected. You must uninstall the previous installation before continuing".
FIX:
Manually remove the previous installation from the registry of the client.
1. Run regedit.exe and remove following keys
The following registry keys needs to be removed:
HKEY_CURRENT_USER\Software\PSC\PROGRESS\<version>
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\<version>
HKEY_LOCAL_MACHINE\SOFTWARE\PSC\SHARED
2. Perform the NetSetup on the client again.