Kbase P38358: Errors 8127, 8119, FSM ERROR, 8121 and 8087 written in WebSpeed broker log file
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  17/01/2008 |
|
Status: Verified
FACT(s) (Environment):
All Supported Operating Systems
WebSpeed 3.x
SYMPTOM(s):
Errors 8127, 8119, FSM ERROR, 8121 and 8087 written in WebSpeed broker log file
ServerSocketsIPC read() IOException : java.io.EOFException : NULL (8127)
ServerSocketsIPC <operation> IOException : <IOException_string> : <IOExceptionMsg_string> (8127)
ServerIPCException in getServerIPCMsg() : ServerIPC error. (8119)
ServerIPCException in <funcName> : <ServerIPCException_string>. (8119)
FSM ERROR: INVALID ACTION state= 2 event = 13 : FSM : action= 17 nextstate = 11
FATAL ERROR : (2) Protocol Error. (8121)
FATAL ERROR : (<rspcode>) <errMsg>. (8121)
Client FSM Error : Invalid ACTION for STATE : state= 0 STATE_IDLE event= 8 EVENT_ERROR action= 10 nextState= 9 STATE_OBLIVION . (8087)
Client FSM Error : Invalid ACTION for STATE : state= <state> <descState> event= <event> <descEvent> action= <action> nextState= <state> <descState>. (8087)
CAUSE:
These errors are expected. They are a consequence of a WebSpeed agent process being manually terminated, or when the process crashed.
FIX:
If the agent process unexpectedly crashed, or was manually terminated (because it was hung), examine the protrace file and/or core file. These files reside within the agent's working directory.
On 3.1D01/9.1D01 and higher, turn on 4GL Tracing to see what the agent was doing before the agent process hang/crash occurred.