Kbase P3747: Self-service clients crash with error reading PROMSGS
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  25/11/2003 |
|
Status: Unverified
FACT(s) (Environment):
HP-UX 11 64-bit
FACT(s) (Environment):
Progress 9.1C
FACT(s) (Environment):
Progress 9.1x
FACT(s) (Environment):
Sun Solaris SPARC
SYMPTOM(s):
Self-service clients crash with:
errno=0 reading PROMSGS file, it may have been deleted.
errno=28 reading PROMSGS file, it may have been deleted.
errno=22 reading PROMSGS file, it may have been deleted.
errno=98 reading PROMSGS file, it may have been deleted.
CAUSE:
The errors are sent from the client. It is the client having the problem reading the PROMSGS file. This behavior has been seen to occur when the PROMSGS file is located on the network and when the network becomes more loaded, these errors can start to appear.
FIX:
1. Place a copy of the PROMSGS file onto the client machines; and
2. in the client startup procedure use the environment variable PROMSGS, referencing this local file.
The context of the errors and the associated errnos could indicate a network problem, so the system should be checked as well.