Kbase P37410: Getting errors 1252 and 1451 when attempting to connect to a
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  08/12/2003 |
|
Status: Verified
FACT(s) (Environment):
Oracle
FACT(s) (Environment):
Oracle DataServer
FACT(s) (Environment):
Windows
SYMPTOM(s):
Getting errors 1252 and 1451 when attempting to connect to a remote Oracle database.
ORACLE error see "ORACLE Error Messages and Codes Manual". (1252)
ORACLE error - 1012 see "ORACLE Error Messages and Codes Manual". (1252)
Failed to connect to ORACLE database . (1451)
Cannot connect to ORACLE instance when using SQLPLUS through PROENV shell, getting ORACLE error -12154.
ORA -12154: TNS could not resolve service name.
Can connect to ORACLE instance via Oracle's SQLPLUS GUI Tool without any problems.
Using ORACLE service to connect to remote ORACLE instance.
The ORACLE_HOME environment variable is properly set.
The TNS_ADMIN environment variable is not set.
The username exists within ORACLE.
User that connects to ORACLE has all correct privileges.
TNSPING "ORACLE_SID" returns OK.
CAUSE:
When using an ORACLE service to connect to an ORACLE instance, Progress always uses the TNSNames.ora file within directory %ORACLE_HOME%\network\Admin, unless TNS_ADMIN variable is set. ORACLE service that is being used to connect to ORACLE instance is not defined within TNSNames.ora file.
FIX:
To be able to access an Oracle database from Progress, configure a Local Net Service Name using the Oracle's Net Configuration Assistant Utility and then specify the created service name within the connection parameters string in the Progress Data Administration Tool.