Kbase P36708: Client crash with file access errors 9445, 9450 or 4229 on Windows due to 3rd party programs
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  23/06/2009 |
|
Status: Verified
SYMPTOM(s):
Client crash with file access errors on Windows due to 3rd party programs
SYSTEM ERROR: read wrong dbkey at offset <offset> in file <file> found <dbkey>, expected <dbkey>, retrying. (9445)
<function>:Insufficient disk space during read, fd <file descriptor>, len <bytes>, offset <bytes>, file <file-name>. (9450)
SYSTEM ERROR: Index <index-num>, block <dbkey>, element no. <element-num>: bad key size in a leaf block. (4429)
SYSTEM ERROR: wrong dbkey in block. Found <dbkey>, should be <dbkey2> (1124)
Errors reported problems with DBI file which is temporary file used by client process.
FACT(s) (Environment):
Progress 9.x
OpenEdge 10.x
Windows
CAUSE:
3rd-party software blocking access to client temporary files (dbi*, lbi*, srt*) .
Known examples of 3rd party software that can cause this are Veritas backup software and a number of anti-virus packages that perform "on-access" scanning
FIX:
Configure the 3rd-party software to exclude directories containing client temporary files.