Kbase P36300: Error 785 when starting database but database still appears to work correctly.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  2/23/2010 |
|
Status: Verified
SYMPTOM(s):
Error 785 when starting database but database still appears to work correctly.
port is already in use (785)
FACT(s) (Environment):
Client/server connections might still work correctly.
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
You have configured more than one Secondary Login Broker for your database and one of them is trying to use a port number that is already in use.
You can confirm this by looking at the database log file. Have a look at the log details at the time of startup and see if you can find something like:
08:34:25 BROKER 1: The port 2519 is already in use. (785)
BROKER 0 is the primary broker and BROKER 1 is a second broker and so on.
FIX:
Check the appropriate Secondary Login Broker by using either Progress Explorer or manually by editing the properties/conmgr.properties file.
Once you have found the offending broker you can then change it to something that is not already being used by another process.