Consultor Eletrônico



Kbase P35574: NameServer shuts down (8202) (9362) (9411) (9412)
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   6/9/2004
Status: Unverified

FACT(s) (Environment):

Windows NT 32 Intel/Windows 2000

SYMPTOM(s):

Name Server at Host localhost Port 5162 is not responsive. (8239)

Response sent to <Host> <Port>. (8202)

An error occurred while listening for network input requests on port <port>. (9362)

An exception occurred. Error message: Connection reset by peer: Datagram peek failed. (9411)

Multiple I/O exception errors on port 15210, the NameServer is shutting down. (9412)

NameServer shuts down

CAUSE:

The Name Service stops functioning (eventually dies with many 9362 and 9411 messages followed by the final 8412 message in the NS.log file) as soon as it receives a request from an IP address that it cannot respond to.

This address <host> is reported in (8202) message immediately preceding the first instance of (9362) and (9411) messages. In this case it was a VRRP address of a Firewall at one of the Web Hosting centers that the Name Server can't talk to. The NameServer should not be receiving traffic/requests from this address.

FIX:

This is a known Progress issue. The NameServer should not shut down after receiving the erroneous request.

If the TCP is not configured properly and the Name Server is in use, then on the one hand it is expected that this situation should not be allowed. Regardless of this issue being fixed, the server should not be receiving traffic/requests from the errant address (as reported in the 8202 message) and this needs to be rectified.

On the other hand, Progress should be trapping this as a Denial of Service Attack and the Name Service should not stop completely on a single no response error.