Consultor Eletrônico



Kbase P35520: Not all agents show the same information when accessing the same record/data
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   20/08/2006
Status: Unverified

FACT(s) (Environment):

OpenEdge 10.x
WebSpeed 3.x

SYMPTOM(s):

Not all agents show the same information when accessing the same record/data

Same NO-LOCK query show different data

Character client shows correct record results

CAUSE:

The WebSpeed agents not flushing the dynamic buffer or cache from buffer pool. This is an expected behavior.

FIX:

There are several workarounds to overcome this problem:

1. User "-rereadnolock" client startup parameter on the WebSpeed agent's startup parameter, and restart the broker.

or,

2. Use STATEMENT before reading the old buffer

or,

3. Use FIND CURRENT or GET CURRENT to re-read the record