Kbase P3438: ProControl: Cannot Find Lock (.lk) file when trying to start
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  14/04/2003 |
|
Solution ID: P3438
FACT(s) (Environment):
Windows 32 Intel
FACT(s) (Environment):
Windows NT 32 Intel/Windows 2000
SYMPTOM(s):
Cannot Find Lock (.lk) file. See EVENT VIEWER
Using ProControl to start database.
ProService is started with the System Account.
Database on a NTFS partition.
CAUSE:
By default NTFS drives are set to allow Everyone Full Control. If the permissions were altered, in this case 'Everyone' had been removed, therefore the account used to start ProService could not access the database.
FIX:
The user account that starts the database needs to have a minimum of read and write permissions on the folder and files of the database. In this case it is the account that is used to start the ProService service.
Make sure the account used to start ProService has the required permissions on the folder and files where the Progress database is stored (at least Read/Write).
The default account used is the 'System' account, but this can be changed.