Kbase 15602: Progress client 7.X/8.0 can not load Oracle library, error 2011
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  3/6/2002 |
|
Status: Unverified
FACT(s) (Environment):
Progress 7.x
Progress 8.x
SYMPTOM(s):
Client has multiple versions of SQL*NET (Oracle client) on machine
Could not load Oracle library library-name. DataServer not started (2011)
Progress client receiving error 2011 when connecting via SQL*NET to Oracle
CAUSE:
Progress cannot find the specified DLL. If you have multiple DLLs within the SYSTEM PATH, Progress client always uses the latest version of SQL*Net client DLL.
In Progress Version 7.X, Progress only uses ORA7WIN.DLL (for SQL*Net 2.0).
In Progress Version 8.0A, Progress searches the PATH for SQL*Net DLL's in the following order:
ORA72.DLL - SQL*Net V2.2.2.1.0
ORA72WIN.DLL - SQL*Net V2.2
ORA71WIN.DLL - SQL*Net V2.1
ORA7WIN.DLL - SQL*Net V2.0
FIX:
Rename other DLL’s in the PATH not used by Progress. If you need to use an older version of SQL*Net, you must ensure that any DLL's for the newer version of SQL*Net doesn't exist within the PATH.