Consultor Eletrônico



Kbase P3366: Unable to connect to database and getting error when trying to run Report Builder from network
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   18/09/2008
Status: Verified

SYMPTOM(s):

Trying to run Report Builder report from 4GL application.

Progress client is run from network drive.

Unable to connect to database and getting Report Builder error

ERROR: Report Builder has detected that the SQL engine has shut down due to a database error. Please save your report exit and restart Report Builder.

FACT(s) (Environment):

Progress 8.x
Progress 9.x
Windows

CAUSE:

There are a number of known issues when running the Report Engine from a 4GL application using a shared network deployment of Progress.

FIX:

Things to check if this error message occurs are:

1. Make sure that the shared network deployment was performed by running NETSETUP on the clients, not by simply mapping to a network drive.

2. Check to make sure the TEMP directory and working directory are valid, the users have write permission on them, and they are not read only.

3. Make sure that "ini2reg.exe" has been run on the client which is needed to add the entries from the progress.ini file into the registry.