Kbase P33612: Error 'Cannot open library file ' after e-mailing a Report B
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  9/5/2003 |
|
Status: Unverified
FACT(s) (Environment):
Citrix MetaFrame (for Windows NT 4.0 Terminal Server)
FACT(s) (Environment):
Progress 9.1D
SYMPTOM(s):
Error "Cannot open library file <LibrarayName.PRL>" after e-mailing a Report Builder report from the 4GL application.
The first time it works fine. After that the error will be generated and the user cannot print, display, or e-mail anything until the user exits the application and starts a new application session.
CAUSE:
The code involves a loop that does not properly release all MAPI resources.
FIX:
Modify the loop to make each iteration spawn a separate Progress application session that e-mails one report and invokes a fresh and separate "MAPI.session" using code similar to:
REPEAT:
/* code to define the report to print in this current loop */
DEFINE VARIABLE cCommandLine AS CHARACTER NO-UNDO.
ASSIGN
cCommandLine = '"C:\PROGRESS91D\bin\prowin32.exe" -p ProcedureName.p'.
OS-COMMAND NO-CONSOLE VALUE(cCommandLine).
END.