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Kbase P3329: Investigating process hangs when appserver stopped with asbman
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   07/07/2009
Status: Verified

SYMPTOM(s):

process hangs when appserver stopped with asbman

query the AdminServer not responding

can't find error messages in the logfiles

JDK version correct for environment

FACT(s) (Environment):

The appserver is in state-reset mode
scripts start and stop the database server
not starting the database with the AdminServer command (dbman)
All Supported Operating Systems
Progress/OpenEdge Product Family

CAUSE:

When the database is backed up:

1) AppServer is stopped with "asbman -i name -stop",
2) Database server is stopped with proshut,
3) Database backed with probkup,
4) Start the database server with proserve, and then
5) Start the appserver again with asbman.

[NOTE: The AdminServer is not stopped - shouldn't need to]

When the appserver is stopped with asbman, this process hangs (step #2)

When querying the AdminServer, it does not respond.

The reason is that AppServer might not have been disconnected after a job was run from the client.

FIX:

As an immediate workaround:

1) Manually kill all the Java processes associated with the Progress session that is running,
2) Start the AdminServer again
3) And then the script executes as it should from step #2

In order to investigate why the AppServer is not disconnected, Insert an "asbman -q -i" before the "asbman - i stop"

This will enable verification of any procedures still locking the appserver (preventing the stop) before issuing the stop. These can then be investigated and their connections terminated before issuing the asbman -i stop.