Consultor Eletrônico



Kbase P3253: Database Recovery if DB and BI files are out of sync in 9.1B
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   25/01/2006
Status: Verified

FACT(s) (Environment):

Progress 9.1B

SYMPTOM(s):

Non-Progress copy of database from one platform to another platform.

Last open date mismatch. (9215)

Extent <file-name> has a different last opened date <file-name>. (9213)

Control Area has a last open date of <time-stamp>. (9217)

Probable backup/restore error. (605)

Database is damaged, see documentation. (1486)

bkOpenControlArea error. (7104)

prostrct unlock does not fix these errors.

A good backup does not exist

CAUSE:

Bug #20010426-008

CAUSE:

When copying a database from one machine to another using a non-recommended copying option, the Before-image (BI) or DB files may become out of synch and fail when attempting to start the database.

FIX:

If this problem occurs, the normal solution is to restore from the last good backup. If this is not possible then use the "prostrct unlock" command.

In Progress 9.1B, the "prostrct unlock" command may not resolve this problem due to a bug.

The solution is to obtain a _dbutil.exe file from a 9.1C installation and use this file to run the "prostrct unlock" command. Issuing the "prostrct unlock" command with the 9.1C _dbutil.exe will fix these errors. After the "prostrct unlock" is ran restore the _dbutil.exe with the 9.1B version.