Consultor Eletrônico



Kbase P3245: Error (5832) -- All WebSpeed agents are currently busy
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/03/2003
Solution ID: P3245

FACT(s) (Environment):

WebSpeed 3.x

SYMPTOM(s):

Msngr: Disconnecting - all agents are currently busy, please try again later. (5832)

All agents are BUSY

All agents are hung in BUSY status

Agents become busy and will not become available

CAUSE:

The maximum agents value in Pool range of WebSpeed agent properties is set too low.

FIX:

Increase the maximum agents value in WebSpeed.

Choose one of the following ways to make the changes:
(Progress recommends you use the Progress Explorer for such changes.)

Via Progress Explorer:
1) Select your WebSpeed Broker.
2) Right-click on the BrokerName and select properties.
3) Expand Agent.
4) Select Pool Range.
5) Increase the maximum agents value.
6) Click OK to apply the changes.
7) Restart your WebSpeed broker.

Via ubroker.properties:
1) Edit $DLC/properties/ubroker.properties.
2) Find .WS.yourbrokername section.
3) Modify/Add line with maxSrvrInstance (increase the number of agents).
4) Save the file.
5) Restart your WebSpeed broker.