Kbase P3232: Snap-in Failed to Initialize after applying patch 9.1C22 or later
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/15/2008 |
|
Status: Verified
FACT(s) (Environment):
Progress 9.1C
Windows
SYMPTOM(s):
Error when starting the Progress Explorer
Snap-in Failed to Initialize
Progress Explorer fails to start with snap-in error
CHANGE:
Patch 9.1C22 (or later) was installed.
CAUSE:
BUG# 20020425-031
CAUSE:
This is a known issue - prox.dll and proexptlr.dll have not been registered after patch application.
FIX:
For 9.1C, the proexptlr.dll and prox.dll files must be re-registered after the patch installation.
To do this, follow the steps in listed in Step 4 of the INSTALLTION NOTES section of the README.PAT file included in the patch zip file.
1. To registry the "prox.dll" file.
From the "Start" button, select "Run...". Enter the following command:
[PROGRESS]\bin\regsvr32.exe [PROGRESS]\bin\prox.dll
and click on the "OK" button.
2. For correct operation of Progress Explorer register the new "proexptlr.dll" file.
From the "Start" button, select "Run...".
Enter the following command:
[PROGRESS]\bin\regsvr32.exe [PROGRESS]\bin\proexptlr.dll
and click on the "OK" button.