Kbase P3230: Fathom messages are badly formatted
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/15/2008 |
|
Status: Verified
FACT(s) (Environment):
Fathom 1.0A
Progress 9.1C
SYMPTOM(s):
Reports and alerts producing strange unformatted messages
Seeing following messed messages when reading alerts using Fathom "LUSIVE-LOCK must be in a DO/REPEAT TRANSACTION. (2819)ound. (2826)
s. (2868)
procedures (and sub-procedures). (2882)
ing will proceed, but no r-code will be generated. (2884)
s. (2890)
(2894)
{0}. (2898)"
Fathom cannot be started
CAUSE:
Fathom installation is linked to Progress installation. Progress promsgs file ($DLC/promsgs) is out of date.
FIX:
1) Download latest promsgs file for Progress 9.1C from TechSupport Site
2) After extracting the files, you will see two directories, prohelp and prolang and a README file. These directories correspond to the $DLC/prohelp and $DLC/prolang directories installed with the core product. The README file contains the directions for updating your Progress messaging System. Backup the $DLC/prohelp/msgdata and $DLC/prolang directories before copying in the new files. Please follow the directions below to extract and update your Progress 9.1C messaging system for use with Fathom
3) Then delete $FATHOM/config/fathom.xml (previous badly formatted messages are stored there) and $FATHOM/config/fathom.properties
4) Restart the AdminServer