Consultor Eletrônico



Kbase P3229: Unable to connect to Admin Server Progress 9.1C on Windows
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   10/20/2003
Status: Unverified

FACT(s) (Environment):

Progress 9.1C

FACT(s) (Environment):

Windows 32 Intel

SYMPTOM(s):

Unable to connect to Admin Server. Ensure Admin Server is running. (8336)

CAUSE:

On Windows, the AdminServer can be manually started as a service through the AdminService. It can also be started automatically as well as manually from the command line within proenv through proadsv -start. In both cases the executable to start the AdminServer is jvmStart.exe. jvmStart.exe, in turn, picks up the needed information to start the Java virtual machine with java.exe from the Registry. This picked up information includes the classpath environment, the Java runtime executable to use, the Java virtual machine start parameters, etc.

During installation, sometimes the Registry keys are not created properly. This especially happens if the Registry update utility from the operating system gets confused because Registry keys from old Progress installations are still there. The result is that the jvmStart.exe is sometimes able to start the AdminServer, but because of incomplete or wrong registry key entries that it reads, it doesn't
function properly. This can cause connection failures to the AdminServer.

FIX:

If the Java virtual machine isn't starting, no log files exist for the AdminServer, or within as WorkPath set key information. So, finding the source for the problem that way isn't possible.

A quicker debugging technique is to try to start the AdminServer within proenv with a modification of proadsv.bat where "-m silent" is removed in the line beginning "%JVMSTRT%..." under the START label. This can help to find the cause of the problem; or, add to the -verbose option if the information is still insufficient. These steps help in detecting the problem, rather than solving it.
To resolve the problem more internal information is needed. It's important to know that the Java virtual machine on which the AdminServer is running with Progress Version 9.1C, is started by java.exe instead of jre.exe from previous versions, and under:

HKEY_LOCAL_MACHINE\SOFTWARE\PSC\PROGRESS\9.1C\JAVA

the keyinfo JVMEXE needs to point to the Java executable instead of jre.

Also, a command started by the current user account is reading the Registry entries under:

HKEY_CURRENT_USER

while the AdminService, by default started as System Account, cannot read those entries and will therefore read the same Registry entries under

HKEY_LOCAL_MACHINE