Consultor Eletrônico



Kbase P3156: Error 8127 when starting AppServer agents
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/10/2008
Status: Verified

FACT(s) (Environment):

Progress 9.X
UNIX

SYMPTOM(s):

Error 8127 when starting AppServer agents

ServerSocketsIPC localhost IOException : {1} : {2} (8127)

ServerSocketsIPC <operation> IOException : <IOException_string> : <IOExceptionMsg_string> (8127)

CAUSE:

Installation files have been moved after primary installation as well as ownership of Progress core files has been changed to non-super (root) user.

Installation path is tailored into progress core files and cannot be easilly moved. Core files needed root permissions to bypass OS limits.

FIX:

Reinstall Progress correctly under root user without further installation moving and changing file ownership.