Kbase P3070: What could cause error 2661 and error 3765
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  18/10/2007 |
|
Status: Verified
FACT(s) (Environment):
All Supported Operating Systems
Progress/OpenEdge Versions
SYMPTOM(s):
Disconnect from server, server received invalid message code (2661)
Message recvd while waiting: uc_wait=1, msg= (3765)
Message recvd while waiting: uc_wait=1, msg=22 (3765)
Message recvd while waiting: uc_wait=1, msg=41 (3765)
Message recvd while waiting: uc_wait=1, msg=50 (3765)
Usernum terminated abnormally. (794)
CAUSE:
There can be various reasons for these error messages. The following is a broad description of error 3765 which is seen at the client side as error 2661:
"What is happening is that the server has received a request from a client and in processing it found that there was a resource conflict of some sort (most likely a record lock conflict). The conflict must be resolved before processing the request can continue. The server will have sent a "please wait" message to the client and gone on to service requests from other clients. At this point, the waiting client has to either continue waiting until the request is satisfied, or cancel it.
The error message means that the client has not done either of these things but has instead sent another request of some sort. This is not allowed because the server can't start working on a new request for the same client until the previous one has been dealt with."
The reasons can be:
1. Network problems.
2. A problem with the programming logic.
3. A bug (if it is reproducible).
FIX:
1.
If it is a network problem it needs to be checked out by a qualified network engineer. This is out of the scope of Progress Technical Support.
2.
You can avoid this by using NO-ERROR NO-WAIT. This is an example:
FIND FIRST pacient SHARE-LOCK NO-ERROR NO-WAIT.
DISPLAY LOCKED(pacient).
UPDATE pacient.