Consultor Eletrônico



Kbase P3030: Unable to uninstall or reinstall Progress on Windows after a failed install
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   01/12/2009
Status: Verified

SYMPTOM(s):

Unable to uninstall or reinstall Progress after a failed install

Some Progress registry keys were created after the failed install

FACT(s) (Environment):

Progress 8.x
Progress 9.x
OpenEdge 10.x
Windows NT 32 Intel/Windows 2000

CAUSE:

During installing Progress, the install process failed for an unknown reason. Registry keys should be removed after failed install or uninstall

FIX:

Clear following registry entries:

1. Remove all registry entries related to the Progress version

1a. If no other version of Progress is installed:

Run REGEDIT from Start -> Run

Delete the following Branches from the Registry:
My Computer\HKEY_CURRENT_USER\Software\PSC
My Computer\HKEY_LOCAL_MACHINE\Software\PSC


1b. If more than one version of Progress is installed and used:

From the following branches, you must check each sub branch and delete each branch related to the version of Progress you wish to remove.

My Computer\HKEY_CURRENT_USER\Software\PSC
My Computer\HKEY_LOCAL_MACHINE\Software\PSC

2. Reboot Windows machine

3. Logon as local administrator and not on the domain.

4. Perform complete install again.