Consultor Eletrônico



Kbase P2931: (290) error on Progress clients using Windows Terminal Server and/or Citrix Metaframe
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   15/10/2008
Status: Verified

FACT(s) (Environment):

Citrix MetaFrame (for Windows 2000 Terminal Server)
Citrix MetaFrame (for Windows NT 4.0 Terminal Server)
Windows NT 4.0 Terminal Server Edition
Windows 2000

SYMPTOM(s):

Intermittent Progress client disconnection using Terminal Server and or MetaFrame

SYSTEM ERROR: I/O error n in program, ret n, file n, addr n. (290)

SYSTEM ERROR: I/O error 22 in readit, ret -1, file 7, addr 0. (290)

Application files or executables located on file server on Terminal Server or Citrix machine.

No hardware issue on the server system

CAUSE:

This was caused by a known Microsoft Bug:
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q272582

This problem can be caused when the user that first opened the shared file logs off. The Terminal Server incorrectly closes the file handles that it has open to the remote file, so any other programs that had the file open are no longer able to access the file. Note that this problem does not occur if the data files are moved to a local volume on the Terminal Server.

FIX:

Fixed in Service Pack 3 of Windows 2000