Consultor Eletrônico



Kbase P29070: Webspeed is losing connections to database
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   12/09/2008
Status: Verified

SYMPTOM(s):

Webspeed is losing connections to database

Error is displayed in browser
CGI Error
The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:

Using cgiip with IIS on the same machine as webspeed transaction server

Switching to wsisa.dll displayes

Database not connected

Ping command shows the database connected, the next minute, the connected database dispears

Firewall between database and transaction server

Connection timed out on socket=<n> for usernum <n>, attempt disconnect. (1280)

Error 1280 in database lg file against the webspeed agant user

Restarting WebSpeed sometimes corrects error

Database's minport is configured higher than maxport

Database shut down w/o WebSpeed shut down

FACT(s) (Environment):

WebSpeed 3.1B
Windows NT 32 Intel/Windows 2000
No errors in WebSpeed broker and server log files
Rebooting Webserver did not change the behavior
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x

CAUSE:

Firewall configuration did not consider minport and maxport

FIX:

1. Configure -minport and -maxport and firewall to allow agents to communicate with database server
2. Configure webspeed min agent to 0 to avoid database disconnect