Kbase P27466: Missing JDBC client components preventing Fathom from communicating with the Trend database
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  1/27/2009 |
|
Status: Verified
SYMPTOM(s):
Error in Fathom Management Console
Error in Admserv.log
FathomTrendingUnavailable: Fathom cannot reach the trend database at <machine:port>. Check the log file for more information. (9892)
Fathom cannot reach the trend database at
jdbc:jdbcprogress:T:localhost:15000:fathomdb. Check the log file for more
information. (9892)
FACT(s) (Environment):
Progress 9.1D
Progress 9.1C
Fathom Management 2.0A
OpenEdge 10.x
Fathom Management 3.x
OpenEdge Management 3.1x
CAUSE:
The Progress installation is missing the JDBC driver necessary for the agent to connect to the Fathom Trend database. This is often a result of a custom or typical installation choice for the Progress install. To confirm, check the installd.ini file. Look for the following entry:
_Component_Progress SQL JDBC Clients - Opt=0
__SubComponent_SQL JDBC Client (m)=0
_Component_Progress SQL ODBC Clients - Opt=0
__SubComponent_SQL ODBC Client (m)=0
The (m)=0 indicates the component or subcomponent was not installed.
FIX:
Reinstall Progress and choose the complete installation option.