Consultor Eletrônico



Kbase P27243: Files in use error when trying to install Progress
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   06/11/2007
Status: Unverified

FACT(s) (Environment):

Progress 9.1x
Windows

SYMPTOM(s):

Files in use error when trying to install

Following files associated with AdminServer are reported to be in use:

dlc/jre/bin/java.exe
dlc/jre/bin/java.dll
dlc/jre/bin/auth.dll
dlc/jre/bin/ini_util.dll
dlc/jre/bin/jut_util.dll
dlc/bin/adminserver.dll
dlc/bin
tjava.dll
dlc/bin/procfg.dll
dlc/bin/versioninfo.dll
dlc/bin/hpi.dll
dlc/bin
et.dll
dlc/bin/verify.dll
dlc/bin/zip.dll
dlc/bin/jvm.dll

AdminServer is shut down

ProService is shut down

Adding a product to an existing installation.

CAUSE:

The installation had been started immediately on shutting down the AdminServer. The associated files had not yet been released.

FIX:

You could just try and wait longer before starting the installation. However, it might also be advisable to ensure that memory has been cleaned up correctly as well, so the following steps should be carried out:

1. Ensure that the AdminService and ProService are set to Manual startup under Services.
2. Ensure that no other Progress processes will be starting automatically on machine startup, e.g. that no batch jobs are run to start databases automatically.
2. Reboot the machine before restarting the installation.