Kbase P27078: Error rlrdnxt:note prefix and suffix lengths don't match, when connecting to a database on a remote
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  2/23/2010 |
|
Status: Verified
SYMPTOM(s):
Error rlrdnxt:note prefix and suffix lengths don't match, when connecting to a database on a remote network drive.
rlrdnxt: note prefix and suffix lengths don't match <prefix length> <suffix length> (9383)
rlrdnxt: note prefix and suffix lengths don't match (5112)
rlrdnxt: note prefix and suffix lengths don't match . (7167)
File <filename> is on a remote system (2226)
Error occurs when either connecting a single user client or starting a multi-user broker against a database that resides on a remote harddrive. e.g. A hard disk not physically connected to the client machine.
FACT(s) (Environment):
All Supported Operating Systems
Progress 9.x
OpenEdge 10.x
CAUSE:
The errors relate to bi file corruption caused by writes to the bi file being damaged or missing.
Because the database files reside on a remote drive the Progress process can't guarantee writes to the database files are complete. In particular the database bi file which is by default written in a RAW mode to ensure the writes actually make it to the bi file. This is part of database integrity.
Anything from hardware errors, reboots, networking faults could cause the remote database to become corrupt.
FIX:
Progress Technical Support does not support databases that have been running in this mode, and we cannot always explain why it may have become corrupt.
Fix the database and then run the database in a supported configuration where the database isn't being started or connected to by a remote client.