Kbase P27020: Can't start Fathom after reinstalling Progress
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  10/5/2010 |
|
Status: Verified
SYMPTOM(s):
Can't connect to Fathom Management Console.
Error attempting to start fathom trend database
Exception in thread "main" java.lang.NoClassDefFoundError:
com/progress/isq/ipqos/admin/cli/FathomMan
FACT(s) (Environment):
Fathom 2.0A
OpenEdge Replication
All Supported Operating Systems
CHANGE:
Reinstalled Progress
CAUSE:
Reinstalling Progress caused the FATHOMCP value in the HKEY_LOCAL_MACHINE\Software\PSC\Progress\9.1D registry key to be reset to a blank value.
FIX:
Manually reset the values for FATHOMCP:
FATHOMCP=<fathom-install-dir>\jars\javax.servlet.jar;
<fathom-install-dir>\jars\org.apache.jasper.jar;
<fathom-install-dir>\jars\fathom.jar