Kbase P26581: PROREST session fails with: is not a Progress backup volume (1059)
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  30/04/2009 |
|
Status: Unverified
SYMPTOM(s):
prorest fails with error 1059
<backup device> is not a Progress backup volume (1059)
!!! ERROR - Database restore utility FAILED !!! (8564)
FACT(s) (Environment):
Windows
Progress 9x
OpenEdge 10.x
CAUSE:
The retore utility (prorest) computed an invalid CRC for the backup header before the restore can continue. In other words, the header information in the backup volume does not correlate with that which is expected in a probkup file. The backup volume is therefore corrupt and cannot reliably be used to restore the contents of the Progress database.
This can be caused by various disk failures and subsequent repair operations have not restored the backup volumes to what they originally were. Another is data loss during backup file volume transfer between one system and another.
FIX:
Restore from an earlier backup.
Revise the DR plan on site with special attention to the location of backup volume placement and ensure that the "Recovery" part of the DR plan is tested at regular intervals.