Consultor Eletrônico



Kbase P26109: Can not start OpenEdge broker when port in use
Autor   Progress Software Corporation - Progress
Acesso   Público
Publicação   5/5/2011
Status: Verified

SYMPTOM(s):

Can not start WebSpeed broker when port in use

Can not start AppServer broker when port in use

Can not start Database broker when port in use

The port <n> is already in use. (785)

Could not listen on port: 3057 (8044)

java.net.BindException: Address already in use

Address already in use

Port already in use

AdminService was brought down for database maintenance

WebSpeed broker was not shut down when admin server was brought down

AppServer broker was not shut down when admin server was brought down

FACT(s) (Environment):

WebSpeed 3.1x
OpenEdge 10.x
All Supported Operating Systems

CAUSE:

The WebSpeed/AppServer brokers are still running on the port although the admin server has been shut down

FIX:

Stop Admin server, identify java processes and stop them using kill command then restart AdminServer and then WebSpeed and appserver brokers.

For example:

For Progress/WebSpeed 3x broker, the broker log file shows the PID after -ubpid

For OE 10x broker, the broker log file shows PID as P-00xxxx, where "xxxx" are the numeric PID number.