Kbase P25132: Can not start Database from ProControl. Cannot Find Lock (.lk) file.
Autor |
  Progress Software Corporation - Progress |
Acesso |
  Público |
Publicação |
  28/03/2005 |
|
Status: Unverified
FACT(s) (Environment):
Windows
Progress 8.x
Progress 9.x
SYMPTOM(s):
Database will not start with ProControl
Cannot Find Lock (.lk) file. See EVENT VIEWER. (5780)
Databases will start when set to auto start from ProControl
Database will start using the proserve command from a command prompt
The ProService Windows Service is set to start as the Local System account.
Logged in as the domain administrator
Problem does not occur when logged into the box as the Local Administrator account
CAUSE:
The users who is attempting to start the databases using ProService is the domain administrator. The Domain Administrator does not have the required local System privileges to interact with the ProService Service.
FIX:
If the desired login user is the domain administrator account, change the ProService Service to start as this user.
To keep the ProService started as local system login as a local administrator to start and stop the databases.